Payter's Cloud Payment Service Maintenance

Scheduled for Jul 14, 06:30 - 07:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 01, 2026 - 14:00 CEST

Scheduled

We recommend subscribing to Payter’s Status Page to stay informed about future maintenance activities:
https://status.payter.com/

Date: Tuesday 14th July 2026
Time: 04:30 UTC / 06:30 CEST
Estimated Duration: Up to 30 minutes

The CPS platform will be undergoing scheduled essential maintenance to update this service. This will include:

Removing a manual suppression of terminal connectivity at 02:00 UTC that was leading to false reports of terminal connection state
Improvements to API user administration, resulting in a faster service
Adding selectedLanguage whilst in Payment to CPS CARD state outputs
Customer should expect terminals to lose connectivity at the beginning of the outage, and the entire terminal estate to recover full connectivity in around 20-30 minutes.

This update improves overall stability, adds a desired feature and removes an historic connection issue.
Posted Jun 23, 2026 - 14:19 CEST
This scheduled maintenance affects: Core services.